An LSIS service
 

NLN Materials

loading loading... Home > Support > Plug-Ins

It is essential that the following plug-ins and up-to-date versions of Internet Explorer, Firefox or Netscape Navigator are installed on college computers for many of the NLN materials to be used successfully. Requirements vary per material, so if you require more detailed descriptions of what is required, please see the tutor guides, available on each Learning Objects' page (or see this page for a complete list of guides).

Browsers

Plug-Ins

Document viewers

Requirements for "The Street"

The Street is a large interactive Learning Object that utilises Adobe Shockwave, and may also have the following additional requirements. A learner using the NLN Materials